Error Message When Using PrintList From Action Dropdown

Feb 16, 2011 at 7:25 PM

Hello,

I have successfully installed and activated this webpart with no error messages. However, when using it under a list libray => Action => Print List, I got this error message:

The file '/_layouts/PrintList/Default.aspx' does not exist.   at System.Web.UI.Util.CheckVirtualFileExists(VirtualPath virtualPath)
   at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
   at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
   at System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean noAssert)
   at System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp, Boolean noAssert)
   at System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath)
   at System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig)
   at System.Web.HttpApplication.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously

Is there something else I was supposed to do to make this work?

Thanks...

 

Feb 17, 2011 at 3:57 PM
Edited Mar 3, 2011 at 4:57 PM

Do you do this in a Site Collection with "no root site" ie. where the root site path is not http://server/ but something like http://server/sites/somesite? We used to have that issue for such sites in such cases in our "semi-free" similar tool PrintZen early on too, ie. static linking to /_layouts/*anypath* causing issues on Site Collections with no "root path" as described above (fixed in PrintZen meanwhile though).